stdd.postinst 554 B

1234567891011121314151617181920212223242526272829
  1. #!/bin/sh
  2. set -e
  3. case "$1" in
  4. configure)
  5. #create the stdd user if it's not already there
  6. if ! getent passwd stdd >/dev/null; then
  7. useradd stdd -d /home/stdd -r -s /bin/false -N -M || true
  8. #add the user to the group i2c
  9. usermod stdd -a -G i2c || true
  10. fi
  11. ;;
  12. abort-upgrade|abort-remove|abort-deconfigure)
  13. ;;
  14. *)
  15. echo "postinst called with unknown argument \`$1'" >&2
  16. exit 1
  17. ;;
  18. esac
  19. # dh_installdeb will replace this with shell code automatically
  20. # generated by other debhelper scripts.
  21. #DEBHELPER#
  22. exit 0