12345678910111213141516171819202122232425 |
- #!/usr/bin/make -f
- # This file was automatically generated by stdeb 0.6.0+git at
- # Sun, 14 Apr 2013 00:45:09 +0200
- %:
- dh $@ --with python3
- override_dh_auto_install:
- python3 setup.py install --root=debian/stov --install-layout=deb --install-lib=/usr/share/stov --install-scripts=/usr/share/stov --install-data=/usr
- # manually compile localization files and copy them into the right directory since distutils don't handle this
- msgfmt locale/de/LC_MESSAGES/stov.po --output-file debian/stov/usr/share/locale/de/LC_MESSAGES/stov.mo
- msgfmt locale/en/LC_MESSAGES/stov.po --output-file debian/stov/usr/share/locale/en/LC_MESSAGES/stov.mo
- mkdir -p debian/stov/usr/share/doc/stov; cp debian/copyright debian/stov/usr/share/doc/stov/
- # Build the man page, also not handled by distutils
- sphinx-build -b man ./doc ./doc/_build/
- override_dh_auto_build:
- override_dh_install:
- find -name '*.egg-info' -exec rm {} \;
- dh_install
- clean::
- if [ -d "doc/_build" ]; then rm -r doc/_build; fi
- if [ -d build ]; then rm -r build; fi
- dh clean --with python3
|