rules 1.0 KB

12345678910111213141516171819202122232425
  1. #!/usr/bin/make -f
  2. # This file was automatically generated by stdeb 0.6.0+git at
  3. # Sun, 14 Apr 2013 00:45:09 +0200
  4. %:
  5. dh $@ --with python3
  6. override_dh_auto_install:
  7. python3 setup.py install --root=debian/stov --install-layout=deb --install-lib=/usr/share/stov --install-scripts=/usr/share/stov --install-data=/usr
  8. # manually compile localization files and copy them into the right directory since distutils don't handle this
  9. msgfmt locale/de/LC_MESSAGES/stov.po --output-file debian/stov/usr/share/locale/de/LC_MESSAGES/stov.mo
  10. msgfmt locale/en/LC_MESSAGES/stov.po --output-file debian/stov/usr/share/locale/en/LC_MESSAGES/stov.mo
  11. mkdir -p debian/stov/usr/share/doc/stov; cp debian/copyright debian/stov/usr/share/doc/stov/
  12. # Build the man page, also not handled by distutils
  13. sphinx-build -b man ./doc ./doc/_build/
  14. override_dh_auto_build:
  15. override_dh_install:
  16. find -name '*.egg-info' -exec rm {} \;
  17. dh_install
  18. clean::
  19. if [ -d "doc/_build" ]; then rm -r doc/_build; fi
  20. if [ -d build ]; then rm -r build; fi
  21. dh clean --with python3